521 errors in certain sites routed through Cloudflare

Incident Report for Imunify360

Update

A fix has been implemented and added to the rollout process. All servers running Imunify360 will receive the update shortly, however, the process can be skipped by forcing the update:

https://docs.imunify360.com/imunifyav/#gradual-roll-out

Update the components:
# wget -O imunify-force-update.sh https://repo.imunify360.cloudlinux.com/defence360/imunify-force-update.sh
# bash imunify-force-update.sh

Restart the corresponding services:
# systemctl restart imunify360
# systemctl restart imunify360-wafd
# systemctl restart imunify360-webshield
Posted Apr 16, 2026 - 15:21 UTC

Monitoring

A fix has been implemented and added to the rollout process. All servers running Imunify360 will receive the update shortly, however, the process can be skipped by forcing the update:

https://docs.imunify360.com/imunifyav/#gradual-roll-out
Posted Apr 14, 2026 - 17:27 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 13, 2026 - 12:28 UTC

Identified

A faulty update may cause issues with some Cloudflare IP addresses.

Workaround: Disable the Webshield service:

# imunify360-agent config update '{"WEBSHIELD": {"enable": false}}'

An update that addresses the problem within the Firewall is being added to the rollout process, and will be available soon.
Posted Apr 09, 2026 - 13:40 UTC
This incident affects: Webshield (SplashScreen).