Imunify360 issue with error 'agent is not running' with 'Tried to start while migrations are not applied' error

Incident Report for Imunify360

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 05:42 UTC

Update

The Imunify360-firewall package 8.12 with the fix is already released to our beta repository and should be available from rollout repos for a while.
--
More details about this package on our changelog portal:
https://changelog.imunify.com/imunify360
Posted Nov 07, 2025 - 09:23 UTC

Monitoring

A permanent fix is ​​ready and will be available in our repositories soon.
Stay tuned for updates.
Posted Nov 04, 2025 - 08:54 UTC

Identified

Panel UI will be reporting that the “Imunify360 Agent Not Running” message.
In /var/log/imunify360/error.log following records can be found:
"WARNING [2025-10-30 09:15:13,561] __main__: Tried to start while migrations are not applied"

Current workaround is running following command in terminal from root account.
"systemctl stop imunify360-agent; systemctl stop imunify360; systemctl reset-failed imunify360-agent; systemctl start imunify360; sleep 5s; systemctl start imunify360-agent"
Posted Oct 30, 2025 - 12:59 UTC
This incident affected: Update services.