Small delay in file uploads/changes over HTTP - Rustbolit 33.3.8

Incident Report for Imunify360

Resolved

The fix has been confirmed in Rustbolit 33.3.9, currently in roll-out. All servers running Imunify360 will receive the automatic update.

Alternatively, the roll-out process can be bypassed:
https://docs.imunify360.com/imunifyav/#gradual-roll-out
Posted May 14, 2026 - 15:46 UTC

Monitoring

A fix has been implemented as we are monitoring the results.

The fixed version "rustbolt-33.3.9-1" is already available from our rollout repositories and can be fetched immediately via this command:
---
dnf update --disablerepo='*' --enablerepo='imunify360-rollout*' rustbolit
yum update --disablerepo='*' --enablerepo='imunify360-rollout*' rustbolit
---
Or through our force-update script:
https://docs.imunify360.com/update/#update-guide
Posted May 13, 2026 - 09:09 UTC

Update

We are continuing to investigate this issue.
Posted May 13, 2026 - 09:07 UTC

Investigating

After the update to Rustbolit 33.3.8, some hosts may still experience issues when uploading files via HTTP or updating scripts via cPanel File Manager. Workaround remains the same:

Disable Imunify360 real-time/inotify scanning:
--
imunify360-agent config update '{"MALWARE_SCANNING": {"enable_scan_inotify": false}}'
--
and/or:
--
imunify360-agent config update '{"MALWARE_SCANNING": {"enable_scan_modsec": false}}'

We will share more details soon.
Posted May 11, 2026 - 14:59 UTC
This incident affected: WAF and Antivirus.