Imunify360 update may cause segmentation fault in PHP 5.6
Incident Report for Imunify360
Resolved
Segfaults were caused by PD rules. A fixed version is currently live and will be propagated to all servers within 30 minutes.
Alternatively, a manual update can be done:
# imunify360-agent update proactive --force
Posted Aug 14, 2024 - 15:03 UTC
Investigating
An upgrade of imunify360-php-daemon and imunify360-php-i360 packages causes a PHP 5.6 segmentation fault:
* sites with PHP 5.6 are showing 503 errors from the web server;
* segmentation fault errors.
Versions 8.1.5-1 and 8.1.5-2 are affected. As a workaround, packages may be downgraded:
# yum downgrade imunify360-php-daemon imunify360-php-i360
The development team is working on a fix.
Posted Aug 14, 2024 - 13:07 UTC
This incident affected: ProactiveDefence.