Fix for the issue is being prepared for beta release with rustbolit 33.3.6 version. Beta release expected on 5th of May (UTC).
Posted May 05, 2026 - 09:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2026 - 12:17 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2026 - 12:09 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 30, 2026 - 10:29 UTC
Identified
File upload or file save operations may take around 10–15 seconds when Imunify360 scanning is enabled.
The issue can appear in one of the following scenarios:
Uploading files through a website when Automatically scan any file uploaded using web is enabled in Imunify360 Saving files through cPanel File Manager Updating files or website content through a web interface The following error can be found in the cPanel logs when the delay occurs during cPanel File Manager save operations: ----- STDERR output from hook: /usr/libexec/imunify360/cpanel_fileman_hook --save
cpanel_fileman_hook: Starting imunify fileman hook cpanel_fileman_hook: save action cpanel_fileman_hook: file /home/USER/tmp/TEMP_FILE is sent for scanning Exception: timed out cpanel_fileman_hook: internal error: timed out
File "/usr/libexec/imunify360/cpanel_fileman_hook", line 178, in aibolit_checker aibolit_job.notify_aibolit_start_it_if_necessary(timeout=remaining_time())
File "/opt/imunify360/venv/lib64/python3.11/site-packages/im360/aibolit_job.py", line 110, in notify_aibolit_start_it_if_necessary sock.send(b"1")
TimeoutError: timed out ------ Environment Imunify360 WHM/cPanel cPanel, DirectAdmin, or modsec
Automatically scan any file uploaded using web enabled in Imunify360 Settings Solution This is a known issue currently handled by the development team. ------------------------
Temporary Workaround
Disable Imunify360 real-time/inotify scanning: -- imunify360-agent config update '{"MALWARE_SCANNING": {"enable_scan_inotify": false}}' -- and/or: -- imunify360-agent config update '{"MALWARE_SCANNING": {"enable_scan_modsec": false}}' imunify360-agent config update '{"MALWARE_SCANNING": {"enable_scan_pure_ftpd": false}}' -- After applying the workaround, reproduce the original action again:
Upload a file through the affected website form, or save a file through cPanel File Manager Confirm whether the upload or save operation completes without the 10–15 second delay Check whether the cpanel_fileman_hook --save timeout no longer appears in the cPanel logs
Cause The delay is caused by a timeout in the Imunify360 scanning flow when the cPanel File Manager save hook or web upload scanning sends a temporary file for scanning. The logs show that the timeout occurs while communicating with the AI-Bolit scanning process.
The fixed package rustbolit 33.3.5 is preparing for release to the beta repo and should be available asap. https://changelog.imunify.com/imunify360 (for checking)
Once the package becomes available, you can update it as follows: -- yum update rustbolit --disablerepo=* --enablerepo=imunify360-testing systemctl restart aibolit-resident.service --